Back to overview
Downtime

Electricity blackout

Mar 14, 2026 at 11:34am UTC
Affected services
EU-PRG01

Resolved
Mar 14, 2026 at 3:13pm UTC

Electricity seems to have foxed itself

Created
Mar 14, 2026 at 11:34am UTC

The PRG-EU01's location is experiencing a blackout. No idea when is going to be fixed